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What This Manual Covers 
The Blackrock Central Software Suite serves three primary functions: 

1. Configuring hardware settings on the Cerebus and CerePlex Direct Neural Signal 
Processors.  

2. Visualizing continuous signals and sorted spikes in real time. 
3. Saving experimental data including continuous signals (.nsx) and digital events (.nev). 

System Description 

The flow of data through the Blackrock Data Acquisitions system begins with a 
biopotential of interest. Potentials are acquired by an electrode well suited to the signal 
and location being recorded. Acquired signals are buffered, amplified, and digitized by 
Blackrock headstages. Finally, data is processed, visualized, and saved by the Central 
Software Suite utilizing a Blackrock Neural Signal Processor. The system can perform 
real-time signal processing algorithms including: noise cancellation, digital filtering, 
simultaneous extraction of spike and field potentials, manual and automatic online spike 
sorting.  

Minimum System Requirements 

Microsoft Windows 7 Professional or Windows 10 Professional  

AMD or Intel 2.0 GHz Quad Core CPU 

4 GB of RAM 

1GHz Ethernet adapter 

1 TB 3 Gbit/s SATA II HDD 

 

A Host PC that is configured and tested by our engineers is available. Please contact 
sales@blackrockmicro.com for more information. 

Setup 

Installing Central Software Suite 

1. Uninstall any previously existing versions of Central Suite through 
Programs and Features in Windows Control Panel. 

2. Run the Central Suite installer (.msi) from the installation CD or 
Blackrockmicro.com. 

3. Install the MATLAB Compiler Runtime from the supplied installation CD or 
Blackrockmicro.com. 

Blackrock recommends that a dedicated PC be used to run Central. Refrain from 
installing any additional software or connecting the PC to the internet.  
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Configuring an Ethernet Port 

The Blackrock Neural Signal Processor communicates with a host PC over the 
UDP Ethernet protocol. Before installing the Central Software Suite, configure the 
Ethernet connection as shown below. 

Note: If you purchased the Blackrock Host PC, an Ethernet card is pre-installed 
and configured in your PC. 

1. Click on Start and search for “View Network Connections”. 
2. Right click on the correct Ethernet Adaptor, usually Local Area 

Connection, and click on Properties. 
3. Uncheck all services except for Internet Protocol (TCP/IP) or Internet 

Protocol Version 4 (TCP/IPv4). 
4. Click on Internet Protocol (TCP/IP) and click on Properties. 
5. Set IP Address to 192.168.137.1 and Subnet Mask to 255.255.255.0 

Leave all other fields blank. 
6. Click on OK to save changes. 

 

  

 
Figure 1 – Network Connections Window 
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Connecting Multiple PCs to One NSP 

A single Neural Signal Processor can connect to up to 16 PCs running the 
Central Software  

1. Connect the NSP and all PCs to a 1-Gbps network switch which has QoS 
enabled. 

2. Configure each PC as per instructions above, however, IP addresses 
should increment like so: 192.168.137.2, 192.168.137.3, etc. 

Note: For your reference, the NSP’s IP address is 192.168.137.128. 

Connecting Two NSPs to One PC 

A single PC can connect to two NSPs by running two instances of Central.  

3. 1Connect both NSPs to separate Ethernet ports on the PC. 
1. Follow the Configuring an Ethernet Port instructions, for both ports. 
2. Use an IP address of 192.168.137.17 for the second port. 
3. Navigate to the Central executable found in Program Files > Blackrock 

Microsystems. 
4. Create a shortcut to the Central executable. Right click the shortcut and 

edit the Target field to read: "C:\Program Files (x86)\Blackrock 
Microsystems\Cerebus Windows Suite\Central.exe --network 
inst=192.168.137.128 --network central=192.168.137.17 --instance 1 

5. Edit the shortcut name to indicate its connection to the second NSP.   
 

 
Figure 3 – Local Area Connections 

 
 

 
Figure 2 – IPv4 Properties 
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Central 
Central can be run from the desktop shortcut, the Start menu shortcut, or by navigating to the 
executable in the Blackrock Microsystems directory in Program Files. The Central main 
application connects to a Blackrock Neural Signal Processor to configure hardware channels 
and acquire data. Incoming data can be processed and visualized in various ways before being 
saved for future analysis.  

Central Main Window 

The Central Main window provides access to all functions, 
features, and settings within the Central Software Suite.  

Hardware Configuration  contains individual channel 
configurations as well as system settings. The main panel 
displays channels in icon or list view as selected in the tool bar. 
Double clicking selected channels will open the channel 
properties window for editing. Channels are filtered by clicking 
the categories listed on the left pane of the window. Additional 
settings are found under the Settings heading at the bottom of 
the left pane.  

Spike Panel displays detected spikes on the front-end amplifier 
channels in a grid-graph form and is often the fastest way to 
visualize overall system function. If spike-sorting rules are 
defined, the spikes belonging to different units will be displayed 
in different colors. Double click any channel to display the 
Single Neural Channel Window. 

Raster Plot displays the occurrence of spike events on many 
channels over time. All channel types may be shown in this 
window. Continuous traces and comments can also be shown 
on the plot.  

Single Neural Channel displays the selected channel in a 
continuous data trace, strip chart, and waves panel. Use this 
window to define spike sorting rules and to view single channel 
activity.  

Activity Map color codes the firing rate of neurons recorded by each electrode on a two-
dimensional grid. An electrode map file dictates the spatial arrangement of channels. 
Use this window to quickly visualize spike rates over all channels.  

File Storage contains the controls to start and stop recording. Additional settings, such 
as file type, name and path may be edited here.  

Signal to Noise Ratio displays the ratio of signal to noise for each channel. Use this 
window to view and record valuable information about signal quality and electrode 
functionality.  

Neural Modulation displays a histogram of changes in firing frequency over time. Use 
this window to see which channels are recording from neurons with variable firing rates.  

Thresholding allows the user to set a global spike detection threshold as a value or a 
multiplier of the root mean squared signal energy.  

 
Figure 4 – Central Main Application 
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Impedance Tester measures and displays the impedance of each electrode. Use this 
window to assess electrode functionality.  

Crosstalk measures and displays the amount of signal shared between channels. Use 
this window to mark and disable redundant channels.  

N-Trode allows configuration and visualization of N-Trode groups. The Spike Display at 
the top of the window shows spikes on each channel.  The Peak/Valley panel is used to 
define spike units for the group. The Continuous Data Display shows the full signal from 
the group.  

Oscilloscope visualizes the signal acquired by any channel. Use this window to view, 
measure and compare signals with custom triggers. 

Digital Filter Editor is a MATLAB utility that creates custom digital filters which can be 
applied to acquired signals.  

Add Comment creates a time-stamped text comment which is included in the neural 
events (.nev) file.  

nPlay loads and replays saved data files for analysis and re-recording.  

System Load displays the volume of incoming data from the Neural Signal Processor. 

Menu Bar 

The menu bar is found at the top of the Central Main window and contains File, Tools, 
and Windows drop-downs. 

File 

The File menu contains functions to load 
and save various configuration files as 
well as the option to close applications 
and shut down the Neural Signal 
Processing hardware. 

Load System Settings: Load channel 
settings in the ‘.ccf’ and ‘.rcf’ formats. 

Load Sorting Rules: Load system-
calculated Histogram Peak Count sorting 
rules in the ‘.csr’ format. 

Load PCA Basis: Load system-
calculated principle component analysis 
basis vectors in the ‘.cfsd’ format. 

Load Digital Filters: Load digital filters 
in the ‘.xml’ format created by the Digital 
Filter Editor. 

Save System Settings: Saves the 
channel settings currently set in 
Hardware Configuration. 

Save Sorting Rules: Saves spike-
sorting parameters. 

Save PCA Basis: Saves PCA basis vectors calculated during spike sorting. 

 
Figure 5 – Central File Menu 
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Close Applications: Closes Central Suite programs while leaving the hardware 
running. 

Hardware Standby and Close: Closes Central Suite programs and puts 
hardware into standby mode. The system must be in standby mode for firmware 
updates. 

Hardware Shutdown and Close: Closes Central, all its associated applications 
and shuts down the Neural Signal Processor. Manually turn off the system power 
switch to complete hardware shutdown. 

Tools 

The Tools menu contains functions regarding thresholding, spike-sorting and 
general application settings. The spike sorting options are discussed on Page 23. 

Options 

Sets various general options for the Central Software Suite. 

 

Allow Multiple Instances Of  

Allows more than one instance of each checked window type to be 
opened.  

 

Sorting Log Rules 

Sorting rules are the manually or automatically defined spike unit 
classifications used to recognize and separate neural spike events.  

Do Not Log Sort Changes: Disables sort change logging. 

 
Figure 6 – Central Options 
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Log Sorting Changes on ‘Record’: Will automatically log the spike-
sorting model, the signal to noise ratio summary, and the crosstalk 
summary if rebuilt during recording. 

Log Sorting Changes ‘Always’: Will log the spike-sorting model, the 
signal to noise ratio summary, and the crosstalk summary any time it is 
rebuilt. 

Log PCA coordinates on ‘Record’: Will log the spike-sorting model only 
when recording begins. 

 

File Storage App Interface 

Choose to save files in the 2.x interface or the TOC interface. The TOC 
interface is designed to be used in a clinical setting where patient 
information is entered. The 2.x interface is preferable in a research setting 
where files are manually named. For more information of file types see 
Page 32. 

 

Single Neural Channel App Interface 

Allows changes to the channel configuration in Single Neural Channel 
viewer or in the Edit > Properties menu. 

 

Auto Impedance Interface 

Configures impedance testing for the Patient Cable or CerePlex 
headstages. 

 

Autoload System Settings 

Upon opening Central, the ‘.ccf’ file input below will be loaded. If the field 
is left blank, Central will prompt the user to select a ‘.ccf’ file. 

 

Windows  

The Windows menu contains system and software summary information as well 
as shortcuts to Central applications 

About: Displays the version of the software and the firmware of the system. 
These version numbers may be needed if you contact Blackrock support. 

System Summary: Displays average number of units per channel if using 
automatic histogram peak-count sorting. Options to disable cross talking 
channels and launch the impedance tester are also found here. 

 



 

Revision 5.00 / LB-0574 – Research Central Software Suite: Instructions for Use 
© 2019 Blackrock Microsystems, LLC  13 

Hardware Configuration 
The Hardware Configuration panel contains individual channel configurations as well as system 
settings. The main panel displays channels in icon or list view as selected in the tool bar. 
Double clicking selected channels will open the channel properties window for editing. Channels 
are filtered by clicking the categories listed on the left pane of the window. Additional settings 
are found under the Settings heading at the bottom of the left pane.  

Channel Sorting 

Central Suite supports front end amplifier inputs, as well as analog, digital and 
serial inputs and outputs. Channels can be viewed in icon, list, or full row detail 
modes selectable in the tool bar on the toolbar. Each channel can be sorted 
based on function under Signal Types, or based on physical location under NSP 
Channels. 

Configuring Channel Properties 

Select one, or multiple channels in the right pane of the Hardware configuration window. 
Once all channels of interest are selected, right-click then select properties, or click the 
Channel Properties icon in the toolbar. Each channel type, and their respective options 
are described below. 

 
Figure 7 – Hardware Configuration 
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Front End Analog Inputs 

All parameters for front end input channels are listed below.  

Label: A user-defined name for the 
specific channel. Multiple channels 
labels can be automatically assigned 

Digital Range: Fixed entry showing the 
range of digital values that analog 
signals are mapped to.  

Analog Range: Fixed entry showing the 
range of analog values measured. 

Analog Units: Unit of analog signal 
measurement displayed for reference. 

External Gain: Gain value of the 
headstage. All Blackrock systems use a 
gain of 1. 

Enable Line Noise Cancellation: Enables cancellation of 50 or 60 Hz noise. 

Estimate Time Constant: The period over which line noise parameters are 
determined. 

LNC Method: Selects software or hardware line noise cancellation. 

Filter: Select a digital filter to apply to continuous data.  

Graphical Chooser: Visualize the continuous signal filter in place.  

Sampling Rate: Select the sampling rate of data acquisition. 

Channel Chooser: Select the sampling rate for data acquisition on any channel. 

Raw Data: Record raw data stream before filtering or sorting is applied. 

AC Input Coupling: High pass filter to remove DC offset. 

 
Figure 8 – Analog Input Properties 

 

 
Figure 9 – Edit Multiple Labels 
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Software Reference Selection: Apply software referencing to local field 
potential or both Local field potential and spike data. 

Reference Electrode:  Select channel to use as software reference. 

Enable Spike Processing: Allow detection of spike events on channel. 

Filter: Filter selection for spike event processing. 

Graphical Chooser: Allows visualization of the spike processing filter in place. 

Threshold Value: Voltage threshold for classification of a spike event in mV. 

RMS Threshold: Set parameters for auto-threshold calculation. 

Sorting Algorithm: Set the sorting algorithm for a channel as described in Spike 
Sorting on Page 23. 

Enable Amplitude Rejection: Rejects waveforms exceeding a specified 
amplitude. 

Upper/Lower Limit (uV): Voltage limits for amplitude rejection. 

Analog Output 

Analog output properties are accessed from the left side bar of the Hardware 
Configuration window and allows the user to set the properties of the analog 

 
Figure 10 – Filter Properties 
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output ports.  Analog outputs can function as monitor channels, directly mirroring 
signals of interest, or as waveform generators. Each modality has output and 
triggering parameters defined below. 

Label: User-defined channel label. 

Function: Assigns the analog channel function.  

Analog Output: Continuous Monitor 

An analog output channel configured as a continuous monitor will scale a user 
input signal into a plus or minus 5 V output signal.  

Input Range: Input voltage range displayed for reference. 

Output Range: Output voltage range displayed for reference. 

Track Most Recently Selected: When enabled, the channel selected in Spike 
Panel, Single Neural Channel, or Raster Plot view is used as the monitor input. 

Channel: An analog output channel configured as a spike monitor will scale a 
user selected input signal into a plus or minus 5 V output signal. 

Analog Output: Spike Monitor 

An analog output channel configured as a spike monitor will scale a user 
selected input signal into a plus or minus 5 V output signal containing only 
identified spike events. 

Input Range: Input voltage range displayed for reference. 

Output Range: Output voltage range displayed for reference. 

Track Most Recently Selected: When enabled, the channel selected in Spike 
Panel, Single Neural Channel, or Raster Plot view is used as the monitor input. 

Channel: An analog output channel configured as a spike monitor will scale a 
user input signal into a plus or minus 5 V output signal containing only identified 
spike events.  

 

 
Figure 11 – Analog Output: Continuous Monitor 
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Analog Output: Sine Waveform 

An analog output channel configured as a sine waveform generator will produce 
a user defined sine wave on a user defined trigger stimulus.  

Amplitude (mV): Amplitude of the output sine wave. 

Frequency (Hz): Frequency of the output sine wave. 

Offset (mV): DC offset of the output sine wave. 

Wave Number: Select which of five waveforms are configured and used. 

Trigger: Triggering options are explained on Page 18. 

Analog Output: Custom Waveform 

An analog output channel configured as a custom waveform generator will 
produce a user defined waveform on a user defined trigger stimulus. 

Wave Number: Select which of five waveforms is configured and used. 

Number of Phases: Number of voltage phases in the waveform. 248 are 
available. 

Offset (mV): DC offset of the waveform. 

Phase: Selects which phase is being configured. 

Amplitude (mV): Phase amplitude. 

Duration (ms): Phase duration. 

Repeats: Indicates the number of times to repeat the waveform once triggered.  
A value of 0 will repeat the waveform indefinitely.  

 

 
Figure 12 – Analog Output: Sine Generator 
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Analog Output: Triggering 

Sine and custom waveforms can be triggered by different conditions listed below. 

Instant: Waveform triggers when OK or Apply are clicked. 

Digital Input Rising Edge: Waveform triggers when a user defined digital input 
pin transitions from low to high.  A digital input bit must be selected. 

Digital Input Falling Edge: Waveform triggers when a user defined digital input 
pin transitions from high to low.  A digital input bit must be selected. 

Spike Unit: Waveform triggers when a sorted unit is detected on a defined 
channel.  

NeuroMotive ROI: Triggers when a subject enters or exits a selected region of 
interest. 

Extension: Waveform triggers based on custom extension code loaded onto 
hardware. 

Digital Input 

Digital input properties are accessed from the left side bar of the Hardware 
Configuration Window and allows the user to set the properties of the digital input 
ports. Digital inputs can synchronize external hardware and pass digital data into 
neural recordings. Digital Inputs may take on the functions listed below.  

16-bit on word strobe: Reads 16 bits on the rising edge of the strobe pin. 

 
Figure 13 – Analog Output: Custom 
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16-bit on bit changes: 16-bit read when any bit changes from LOW to HIGH or 
from HIGH to LOW. 

16-bit on rising edge: 16-bit read when any bit changes from LOW to HIGH. 
Each bit indicates if a LOW to HIGH change occurred on each digital pin. 

16-bit on falling edge: 16-bit read when any bit changes from HIGH to LOW. 
Each bit indicates if a HIGH to LOW change occurred on each digital pin. 

8-bit strobe / 8-bit bit changes: Reads bits 0-7 on the rising edge of the strobe 
pin and reads bits 8-15 if bits 8-15 changed from LOW to HIGH or HIGH to LOW. 

8-bit strobe / 8-bit bit rising edge: Reads bits 0-7 on the rising edge of the 
strobe pin, and bits 8-15 indicate if digital pins D8-D15 changed from LOW to 
HIGH. 

8-bit strobe / 8-bit bit falling edge: Reads bits 0-7 on the rising edge of the 
strobe pin, and bits 8-15 indicate if digital pins D8-D15 changed from HIGH to 
LOW. 

Digital Output 

The Digital Output Window is accessed from the left side bar of the Hardware 
Configuration Window and allows the user to set the properties of the digital 
outputs. Digital outputs can function as spike detection monitors, timed function 
generators, or triggered events.  

Digital Output: Monitor Electrode 

A digital output in monitor electrode mode will send a high pulse when a sorted 
spike unit is detected on a defined channel. 

Track Most Recently Selected: When enabled, the channel selected in Spike 
Panel, Single Neural Channel, or Raster Plot view is used as the monitor input. 

Source: Select which channel to monitor. 

Monitored Units: Select which spike unit classifications to trigger on. 

 

 
Figure 14 – Digital Output Properties 
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Digital Output: Timed 

A digital output in timed mode will send a pulse train with specified parameters. 
The signal can be configured by setting frequency and duty cycle, or samples 
high and low.  

Frequency (Hz): The number of pulses per second. 

Duty Cycle: The percentage of time a pulse train is high. 

Samples High: Number of 30kHz sample periods output should be held high.  

Samples Low: Number of 30kHz sample periods output should be held low.  

Offset (mV): DC offset voltage of the digital output. 

Digital Output: Triggered 

A digital output in triggered mode will send a pulse when the selected trigger 
stimulus occurs.  

Digital Input Rising Edge: Waveform triggers when a user defined digital input 
pin transitions from low to high.  A digital input bit must be selected. 

Digital Input Falling Edge: Waveform triggers when a user defined digital input 
pin transitions from high to low.  A digital input bit must be selected. 

Spike Unit: Waveform triggers when a sorted unit is detected on a defined 
channel.  

NeuroMotive ROI: Waveform triggers when a subject enters or exits a region of 
interest. 

Extension: Waveform triggers based on custom extension code loaded onto 
hardware. 

Serial I/O 

The Serial I/O Properties window 
displays the serial communication 
parameters and allows the user to 
name and enable the serial port.  Serial 
communication parameters cannot be 
changed. 

 
 
 
 
 
      
 
 
 
 
 

 
Figure 15 – Serial I/O 
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Settings 

Global Settings 

Spike Width (samples): The number of samples recorded around a detected 
spike event.  

Pre-threshold Samples: The number of samples to record preceding a 
threshold crossing.  

Line Noise Frequency (Hz): The line frequency of the system, either 50 Hz or 
60 Hz.  

LNC Reference Channel: The reference channel used to compute system line 
noise. The extracted line noise template for each channel can be viewed in 
Single Neural Channel when the Raw/LNC button is checked. 

  
 
 
 
 
 
 
 
 
 
 

 
Figure 16 – Hardware Configuration Settings 
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Filters 

This window displays the details of a selected digital filter in a bode plot and key 
numerical parameters.  

Auto Thresholding 

This window allows the user to specify the auto thresholding properties for spike 
detection.  

Threshold Multiplier: To register as a spike event, signal energy between 1 and 
5 kHz must exceed the energy of the noise by a factor of the threshold multiplier 
level. 

Channel: Applies noise boundary properties to this channel. 

Dimensions of the Ellipsoid: Radius of the noise ellipsoid in the along each 
axis. 

Center of Ellipsoid: Center of the noise ellipsoid in cartesian coordinates. 

Rotation of Ellipsoid: Rotation angle of the noise ellipsoid around each axis. 

 

 
Figure 17 – Filter Properties Display 
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Spike Sorting 

The Spike Sorting Properties Window allows the user to specify the rules and 
settings for the spike sorting algorithms. The default settings are recommended 
but altered settings may produce better results in unique use cases. Four spike 
sorting methods are available: Manual PCA, k-means PCA, DBSCAN PCA, and 
Histogram Peak Count. Each method is described below. 

Manual PCA 

Manual PCA uses principle component analysis to generate a feature 
point for each spike event.  The user manually defines unit classifications 
by drawing an ellipsoid around each cluster of feature points within the 
feature space. 

Wave Basis Size: The number of waveforms to use to calculate the PCA 
basis vectors.  

Update Basis Multiplier: The PCA basis vectors will be recalculated 
after the number of samples exceeds the basis size times the basis 
multiplier. Zero means don’t recalculate. 

 

k-means PCA 

k-means PCA algorithms automatically generate ellipsoids around k 
number of clusters to sort recorded units.  

Wave Basis Size: The number of waveforms to use to calculate the PCA 
basis vectors.  

Update Basis Multiplier: The PCA basis vectors will be recalculated 
after the number of samples exceeds the basis size times the basis 
multiplier. Zero means don’t recalculate. 

Outlier Removal: Removes outliers exceeding this number of standard 
deviations from the centroid of each group. 

Minimum Group Size: Remove any groups that have fewer than this 
number of spikes. 

Merge Centroids: Merge two groups if the merged group has a standard 
deviation less than this multiplier times the product of the standard 
deviations of both groups. 

Number k-means groups: Number of k-means groups to use for sorting. 

 

DBSCAN PCA 

Density Based Spatial Clustering of Applications with Noise is a principle 
component analysis method that automatically chooses the quantity, 
radius, and position of each cluster based on point density. 

Wave Basis Size: The number of waveforms to use to calculate the PCA 
basis vectors.  
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Update Basis Multiplier: The PCA basis vectors will be recalculated 
after the number of samples exceeds the basis size times the basis 
multiplier. Zero means don’t recalculate. 

 

Histogram Peak Count 

Collected waveforms are broken down into high frequency and low 
frequency components. Each spike event is plotted on an axis composed 
of these two components. A histogram is constructed and clusters are 
estimated by determining peaks and valleys. 

Valley Percentage: A valley is identified at a height less than the first 
peak height times the valley percentage value. 

Close Peak Percentage: The second peak is identified at the height of 
the valley plus the height of the three-point mean centered at the valley 
multiplied by the close peak percentage. 

Freeze Time (minutes): Time spent analyzing the number of units on 
each channel. 

Update Rate (# spikes): The number of spikes that must be collected 
within each unit before the histogram is updated. 

Minimum Peak Percentage: Minimum peak height is calculated by 
adding the valley height to the total number of samples used times the 
minimum peak percentage. 

 

Artifact Rejection 

Maximum Simultaneous Channels: If more than the maximum number 
of channels contain simultaneous spike events, the events are all 
rejected. 

Refractory Period: The number of samples for which spike detection is 
barred after a spike event. 

 
Figure 18 – Spike Sorting Properties 
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Tools Menu 

The main Central Window Tools menu 
contains several Spike Sorting options. 

Thresholding: Set the manual threshold 
level for all channels as an RMS multiplier or 
a fixed voltage value. 

Options: See below. 

Lock Unit Statistics: Disables continuous 
updates of spike sorting rules. 

Rebuild Spike-sorting Model: Restarts the 
automatic spike-sorting function. 

Continuous Spike Sorting: Selecting this 
item will continuously adjust the spike-sorting 
statistics including the splitting and merging 
of units. This is not recommended for use 
while recording.  

Build PCA: Builds the PCA basis vectors for 
all channels with PCA based spike sorting. 

Assisted Spike Sorting: Enable k-means, 
DBSCAN, or all PCA methods for spike 
sorting.  

Adaptive Filtering 

Recorded signals may contain unwanted information from sources of external 
noise, such as magnetic eye-tracking systems, monitors, and subject reward 
systems. The Adaptive Filtering feature can use a noise signal as a reference for 
neural signal channels.  

Adaptive Filtering: Choose one or two channels to reference. 

Reference Channels: Select channels to be used as references. 

 
Figure 19 – Tools Menu 

 

 
Figure 20 – Adaptive Filtering 
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N-Trode Groups 

N-Trode channel groupings are user defined electrode subsets created to record 
signals from proximal regions. When any single unit spike is detected within the 
N-Trode, the signals from all component electrodes are saved and registered as 
events. The Central Suite supports multiple N-Trode sets containing up to four 
electrodes each. Multiple single channels are linked and spike sorting occurs on 
the N-Trode as a single entity. To define N-Trode groups, open a group and add 
channels to it with the arrow buttons or by double clicking.  

  

 
Figure 21 – N-Trode Properties 
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Spike Panel 
Spike panel displays detected spikes on the front-end amplifier channels in a grid-graph form 
and is often the fastest way to visualize overall system function. Double click any channel to 
display the Single Neural Channel window. The layout and graphical settings of the grid and 
individual channels can be changed in the right-click menu or the toolbar. A map file can be 
applied to the display to change the spatial arrangement of the channels on the screen to match 
the electrode array in use. If spike-sorting rules are defined, the spikes belonging to different 
units will be displayed in different colors. 

Spike Panel Settings 

 Load Map File: The default map file for the spike panel is a 16x8 grid. Custom map 
files matching the spatial arrangement of your electrode ship with each Blackrock 
Electrode Array. Contact Blackrock Support at support@blackrockmicro.com for an 
additional copy of this file. 

Load Default Map File: The default channel map will be loaded. 

 
Figure 22 – Spike Panel 
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 Map File Information: Display information about the current map file. 

 Time to Screen Refresh: Set the length of time spike waveforms will trace 
without refreshing. 

 Open Selected Channels: Individual or groups of channels can be viewed by 
selecting Open Selected Channels in the right-click menu or the top menu bar. 

Show Labels: Display channel information on the cursor.  

 Refresh Screen: Manually refresh the spike panel display. 

 Magnify Current Channel: Toggle mouse-hover magnification 

 Spike Scale: Adjust the visual amplitude of displayed spikes. 

 Broadcast Channel Selections: Duplicate channel selection on other instances of 
Central running on computers connected to an Ethernet switch. 

 Level of Criticality: Display the current application load. 

 

Raster Plot 
The Raster Plot displays the occurrence of spike events on many channels over time. All input 
channel types may be added, removed, moved, and scaled in this window. Continuous traces 
and comments can also be shown on the plot. 

Tool Bar 

 Play: Configure the display to fill and then refill repeatedly.  

 Scroll: Configure the display to scroll right to left. 

 Pause: Pause the display. 

 Increase/Decrease Font Size: Change the font size of channel labels. 

 One Line per Channel: Display all units from each channel on one line.  

 Split Channels: Display each unit on a separate line. 

 
Figure 23 – Raster Plot 
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 Seconds per Division: Change the time scale markers on the plot. 

 Decrease/Increase Size: Change the size of selected channels. 

 Minimize/Maximize Size: Minimize or maximize the size of selected channels. 

 Delete: Remove selected channel from the plot. 

 Move Up/Down: Move selected channels through the channel list.  

 Continuous Data Scale: Set the amplitude of continuous signals. 

 Show Neural Events: Display neural events as impulses on the raster plot. 

 Show Continuous Data: Display continuous channel trace. 

 Raw Toggle: Toggle between filtered continuous and raw data. 

 Update: Refresh the display. 

 Sort: Sort channels in the raster plot display by Channel ID, Recording Mode, or Unit 
ID. 

 Choose Channels: Select channels to display. 

 Add All: Display all channels. 

 Clear All: Remove all channels from display. 

 Open Selected Channels: Open selected channels in Single Neural Channel. 

 Broadcast Channel Selections: Duplicate channel selection on other instances of 
Central running on computers connected to the Ethernet switch. 

 Level of Criticality: Display the current application load.   
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Single Neural Channel 
Single Neural Channel visualizes the selected channel in a continuous data trace, strip chart, 
and waves panel. Spike sorting is configured in this window.  

Channel Configuration 

 Channel ID: Select a channel from the drop-down menu. 

 Channel Selector: Scroll through channels.  

 Channel Properties: Open the Channel Properties window. 

 Persist Spikes: When selected, the last detected spikes will remain in the wave 
viewer for sorting. 

 View Tool Tip: Display time and amplitude values at the cursor position. 

 View Continuous: Toggle the Continuous Data Display. 

 View Classification: Toggle the Online Classification Display. 

 Broadcast Channel Selections: Duplicates channel selection on other instances of 
Central running on computers connected to the Ethernet switch. 

 

 
Figure 24 – Single Neural Channel 
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Spike Display 

The spike display panel shows neural events. It contains the wave panel where spikes 
can be visualized and sorting hoops can be defined, as well as the strip chart. Use the 
vertical slide button at the right of the panel to set the voltage range. The default time 
scale of the spike display window is 1.6 milliseconds. The samples width of each spike 
can be defined in the Global Settings section in the Hardware Configuration module 
within a range of 1.0 to 4.3 milliseconds. 

Clear: Clear the spike display. Automatic clearing will occur as well, maintaining the 
number of spikes shown in the drop-down menu. 

Show Spikes: Select which spike units to display. 

Hoops Spike Sorting: To define a spike unit, click Define next to a unit window box on 
the right side of the window. A color box will appear in the lower right of the spike 
window. Drag the selector to include all contacted waveforms in the unit. Only 
waveforms within a selection will be classified. The Define All button will initialize all five 
units. 

Unit Mapping: Select unit definitions to remap, combine, or map to noise. 

3D PCA On-line Spike Classification: If manual PCA is selected, spike sorting is 
performed using online PCA analysis within the PCA space. PCA spike sorting can 
classify up to five different signals per channel, each selected signal receives a separate 
color. An ISI Histogram is also displayed for each classified spike.  

A user can sort an individual channel by clicking on the Feature tab. Click the Define 
button next to the classified spike to sort that unit. Hold the Ctrl key and draw around the 
cluster. An ellipsoid will be created which is used to define a unit. You may also change 
the size of the ellipsoid by pressing R then moving the handle. 

k-means & DBSCAN PCA:  Generates ellipsoids when the k-means or DBSCAN PCA 
is selected in the Feature tab. 

Manual Override Options 

Automatic spike sorting can be overridden on an individual channel by clicking on the 
Pattern view. Click the Edit button next to the classified spike to resort to a manual 
sorting option. Press <C> to see all available controls. Hold down the <Ctrl> key and 
draw an ellipse in the Pattern view around the cluster that you would like to define as a 
spike. You may also change the diameter of the ellipse. Once the ellipse is placed 
around a cluster of points. The word “Overridden” will appear next to the sorted unit.  
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File Storage 
Central Software Suite supports file storage via the TOC and 2.x interfaces. 2.x is the most 
common basic file interface for research. The TOC interface names files with a timestamp and 
patient name, as well as file splitting long recordings. Data files are saved in .nsx format. .nsx 
data is stored in bits with 250 nV/bit resolution. Timestamps appended to filenames by Central 
use Greenwich Mean Time (GMT) referencing your local computer’s clock and time zone 
information. 

TOC Interface 

The TOC interface allows the user to enter patient information and select a path for the 
files that are created when the session is initiated. The Central Software Suite assigns a 
numeric name to the files which indicates the date and time of the recording. For 
example, 20110124-152145 indicates that the data file was recorded on January 24, 
2011 at 3:21:45 PM GMT. System settings will be saved in the same folder as the data 
file. 

File Splitting: Splitting large files into smaller sizes may aid offline analysis. File size 
limit is defined in the View > Options menu. To disable file splitting, check the disable 
file-splitting box in the file storage module. 

File Description: Up to 256-character comments can be entered here to be saved with 
the file. Comments need to be entered prior to recording a data file. 

Record For: Specify an amount of time that the Central Software Suite will record data. 
Once the time has expired, the recording will stop automatically. 

Remote Recording Control: Allows digital in signals to Start, Stop, Pause, and Resume 
file recording through the digital input port, or the serial I/O port. Click the Setup button 
below the remote recording check box to set user-defined hex values for each remote 
recording function. For an example of remote recording control see Page 50. 

 
Figure 25 – TOC Interface 
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Record: Begin recording data. 

Pause: Pause recording. 

Stop: Stop recording and save file. 

 

2.x Interface 

The 2.x interface allows the user to specify a file name and path for the next data set. 
Recording can be started and stopped from this window or set to stop after a specified 
duration. 

File Options: Select sampling frequency of recorded data. 

File Name and Path: Browse to, or type in, the desired file name and path. 

Auto-Increment: Enable automatically incrementing the data file names with an 
appended numeral. 

File Specification: Choose between the different file specifications. It is advised to 
always use the most current specification. 

File Storage Options 

After opening the File Storage Window, options can be found under View menu.  

Enable Sync Pulse: Send a unique waveform pattern every 14 seconds and 
repeat patterns hourly.  

Invert Sync Pulse: Invert the high and low phases of the sync pulse. 

Remove Noise: Do not save waveforms classified as noise during spike sorting. 

Sync with NeuroMotive Recording: Enable syncing with the NeuroMotive video 
recording and tracking system. 

Split File Interval: Enter either a duration or file size limit for each file segment. If 
file size is specified, click on “Calculate Time” to automatically populate the 
“Estimated Time” field. 

 

 
Figure 26 – 2.x Interface 
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Digital Oscilloscope 
The digital oscilloscope can display and measure two input channels on screen at a resolution 
of 0.1 milliseconds per division. Signals can be viewed continuously or on a specified trigger. 
Frequency spectra can also be displayed. 

Channel Enable: Two channels may be viewed per instance of the oscilloscope. 

Channel Selection: Select any channel from the drop-down menu. 

Color Selection: Select a color for either trace. 

Settings: Open the properties window for the selected channel.  

Invert: Invert the trace for a given channel. 

Trace Amplitude: Modifying the sliders for each channel will 
change the signal amplitude. The top slider changes the range 
and the lower slider selects a value within the given range.  

Time/Frequency selection: Set the oscilloscope into time or 
frequency mode. 

Time Resolution: Modifying the sliders will change the time 
resolution of the trace. The upper sliders change the range of 
resolution and the lower slider is used to choose a value within 
the given range. 

 

 
Figure 27 – Digital Oscillloscope View 

 
Figure 28 – Trace Amplitude 
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If no continuous trace is visible on the oscilloscope, confirm that the channel of interest is being 
sampled from in the Analog Input Properties window. If no trace appears despite sampling from 
the channel there may be a compatibility issue with your graphics adapter. Please contact 
Blackrock at support@blackrockmicro.com. 

Trigger Type 

Different triggers can be used to position and display waveforms on the oscilloscope. 

Auto: Continuous signal will be displayed until the trace crosses the user defined trigger 
level.  When the trigger level is crossed, the trace will pause for two seconds, then 
resume until another triggering event occurs. 

Normal: The trace will freeze as soon as the trace crosses threshold until the trace 
crosses the trigger level again in which case the screen will update with the new trace. 

Single: A single trace is captured as soon as it crosses the trigger level. To capture 
another threshold-crossed trace click on Single again. 

Trigger Level: Trigger level can be entered in the field or by manually sliding the trigger 
line on the display. 

Assign a trigger delay: Adjust the trigger position on the time axis. At 0 delay, the 
trigger will be placed at the left edge of the screen and may not be visible. Set a negative 
value to push the trigger point to the right. 
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Digital Filter Editor 
The Digital Filter Editor can generate custom filters to be used in Central Suite. It requires the 
Matlab Compiler Runtime to be installed. Contact support@blackrockmicro.com for a copy of 
this software.  

Filter type and corner frequencies are defined in the Editing Tools section on the left side of the 
window. The stability of the filter is shown in the Filter Status section below. The Bode Plot and 
the Nyquist Plot of the designed filter are displayed. Once the filter parameters are set, click on 
Save to save the digital filter.  

  

 
Figure 29 – Digital Filter Editor 
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Activity Map 
The activity map color codes the firing rate of neurons on a two-dimensional map. An electrode 
map file assigns each channel to a location. The spiking activity of each channel is binned and 
smoothed over a fixed time window of 20 milliseconds. Smoothing adds steps between events 
and non-events both between channels and over time. 

Maximum Scale Range: Set the maximum value of the color scale in spikes per second. 

Scale Eccentricity: Skews the mapping of spike rate to color towards high or low values. 

Time Constant: Set the time constant controlling activity decay. 

Pause: Pause the display until unchecked.  

Reset: Clear current activity data and refresh visualization.  

Load Map File: Load a map file to change the orientation of the display. 

Default Map File: Return to the default 16x8 grid map file.  

  
 
 
 

  

 
Figure 30 – Activity Map 
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Signal-to-Noise Ratio 
Signal-to-Noise Ratio (SNR) displays the running amplitudes of the signal, noise, and signal-to-
noise ratio for units on each channel. It also displays the signal-to-noise ratio as a function of 
time, which allows changes in signal quality to be monitored. This information can be saved as a 
tab-delimited text file and opened in Excel or a compatible program for further analysis. In the 
example below the SNR for elec11 unit 3 is 9.50 meaning that the signal is 9.5 times bigger 
than the noise. 

 
Figure 31 – Signal to Noise Ratio 

 



 

Revision 5.00 / LB-0574 – Research Central Software Suite: Instructions for Use 
© 2019 Blackrock Microsystems, LLC  39 

Neural Modulation 
Neural Modulation displays a histogram of changes in firing frequency over time. The 
Modulation Index is the variance of the histogram entries and covers a range of 0 to 12.0.  A 
range of 2 to 5 is considered normal when recording neural signals. 

Impedance Tester 
Impedance Tester measures and reports electrode impedance on each channel. To function 
properly the impedance mode must be selected in Central, click Tools > Options > Auto 
Impedance Interface. Either mode begins by asking for array information, including the serial 
number, implantation date, type of sterilization and comments.   

 
Figure 32 – Neural Modulation 
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Special equipment may be required for impedance measurements. Contact Blackrock 
Microsystems sales at sales@blackrockmicro.com for more information. 

  

 
Figure 33 – Auto Impedance 
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Crosstalk 
The Crosstalk Diagnostic window compares each channel to identify cross correlation. The 
Crosstalk Diagnostic feature will display each channel as green, yellow, or red, indicating the 
amount of unique signal on each electrode.  

Green: No cross correlation to any other channel was found. 

Yellow: Possible cross correlation found. Examine signals closely to determine best use. 

Red: High levels of cross correlation found. Consider removing these channels from recordings. 

  

 
Figure 34 – Crosstalk 
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N-Trode 
Multiple single channels can be linked into N-Trode channel groupings. These are user defined 
electrode subsets created to record signals from proximal regions when any single unit spike is 
detected within the N-Trode. N-Trodes allow for neural events detected on one channel within 
an N-Trode to force the creation of neural events on the other N-Trode channels. When an 
event is detected on a channel within an N-Trode, all other N-Trode channels record a neural 
event with the same timestamp, spike width samples, pre-threshold samples, and refractory 
period (see Global Settings). Central supports multiple N-Trode sets containing up to four 
electrodes each. Define N-Trode configurations in the Hardware Configuration window or within 
the N-Trode application window. 

Note: Spike sorting occurs on the N-Trode as a single entity. This causes neural events on all 
N-Trode channels to be subject to refractory periods caused by a neural event detected on any 
N-Trode channel. 

 N-Trode: Use the drop-down menu to select an N-Trode group.  

 Scroll: Use the arrows to scroll through N-Trodes. 

 N-Trode Properties: Define or modify an N-Trode group. 

 Channel Properties: Open the Analog Input Properties window for all channels in the 
selected N-Trode group. 

 View Tool Tip: Display time and amplitude values at the cursor position. 

 
Figure 35 – N-Trode Utility 
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 Hide Continuous: Toggle the Continuous Data Display on the bottom of the window. 

 Broadcast Channel Selections: Duplicates channel selection on other instances of Central 
running on computers connected to the ethernet switch. 

Options…: See a list of keyboard and mouse commands to manipulate the N-Trode GUI. 

Spike Display 

Spike Threshold: Adjust the voltage threshold for spike detection on all channels. 

Clear: Clear the spike display. Automatic clearing will occur to maintain the number of 
spikes shown in the drop-down menu. 

Show Spikes: Select which spike units to display. 

Add Comment 
The Add Comment feature allows the user to add a timestamped text comment to the Neural 
Event file. Comments can be visualized in the Raster Plot view. When in the Raster Plot window 
or the Central Main Window, a comment time stamp is initiated by typing and completed when 
the <Enter> key is pressed. 

nPlay Server 
nPlay Server loads and replays recorded neural data in 
‘.nsx’ or ‘.nev’ formats for viewing and analysis in 
Central. When playing back the continuous data files, 
the user can filter, sort spikes, and down sample. A 
Neural Signal Processor does not need to be 
connected to the PC to use this utility.  

 

 

 

  

 
Figure 36 – nPlay Server 

 



 

Revision 5.00 / LB-0574 – Research Central Software Suite: Instructions for Use 
© 2019 Blackrock Microsystems, LLC  44 

How To 

Setup Channels for Data Acquisition 

Central Suite can be configured to work with many distinct combinations of electrodes, 
subject types, and signals of interest. Central Suite can record three data types 
concurrently: Unfiltered continuous signal sampled at 30 kHz, filtered continuous signal 
at a lower sampling rate, and timestamped sorted spike waveforms. Typical channel 
setup is outlined below.  

1. Open Central. 
2. Click on Hardware Configuration. 
3. Select a channel to configure from the nested Signal Types, or NSP menus on 

the left. You can select multiple channels by holding down <control> or select a 
range of channels by holding down the <Shift> key while making the selection. 

4. Right click the selected channel(s) and choose Properties. Alternatively, you can 
click on the Properties icon on the toolbar. 

5. We recommend enabling Raw Data to preserve all recorded data for future 
analysis by checking the Enable box. 

6. The Continuous Acquisition section allows you to select a preset filter and 
sampling rate for recording and visualization. A lower sampling rate may be 
suitable for your studies and will reduce the file size.   

Filter selection depends upon your specific study. In general, local field potentials are 
best measured with a low pass filter, such as LP 150. To properly extract spikes, a high 
pass filter, such as HP 250, needs to be applied to the channel.  

If extracting spikes, check the Enable Spike Processing box and then click Spike View in 
the bottom of the Input Properties window. This will open the Single Neural Channel 
view where spike sorting rules can be configured. 
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Sort Spike Units 

The Central software offers three automatic and manual methods for real-time spike 
sorting.  

Histogram Peak Count (Automatic) 

1. Open the Hardware Configuration window and select channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose Histogram Peak Count from the spike-sorting drop down menu. 
4. Click OK. 
5. In Central, click Tools > Rebuild Spike Sorting. This step may take a few 

minutes and must be repeated for each experimental session. Each time 
the sorting is rebuilt, new classifications are calculated based on current 
data. 

 
Note: To save Histogram Peak Counts sorting rules in Central, click File > 
Save Sorting Rules…. To load Histogram Peak Counts sorting rules, click 
File > Load Sorting Rules…. 

Hoops (Manual) 

1. Open the Hardware Configuration window and select channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “Hoops” from the spike-sorting drop down menu. 
4. Open Single Neural Channel and select the desired channel. 
5. Make sure the view classification icon is pressed down so you can see 

the units window.  
6. Click on the define button for a unit. A series of colored boxes will appear 

on the spike panel in the lower right corner.  

 
Figure 38 – PCA Space 

 
Figure 38 – Sorted Spikes 
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7. Drag each colored box out of its place and an amplitude band will appear. 
8. Place the band so that it intersects spikes to be classified in this unit. 
9. Four bands may be placed for each unit classification. 
10. Five individual units may be defined on each channel. 

 
Note: To save Hoops sorting rules in Central, click File > Save System 
Settings…. To load Hoops sorting rules, click File > Load System Settings…. 

Manual PCA 

1. Open the Hardware Configuration window and select channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “Manual PCA” from the spike sorting drop down menu. 
4. Open Single Neural Channel and select the desired channel. 
5. Make sure the unit icon is pressed down so you can see the units 

window. 
6. Click on the Feature tab. 

 
7. Click on Build PCA. By default the program needs 250 waveforms to build 

the PCA basis vectors. The time required to record 250 waveforms will 
depend on your spike rates and may take several minutes. You can 
modify the number of waveforms used in Hardware Configuration > Spike 
Sorting. 

8. Click the Define button for your first unit. 

 
Figure 39 – PCA Space 
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9. Hold down the <Control> key and draw a line around a given cluster. The 
program will automatically create an ellipsoid around the cluster. Repeat 
this process for all the other units and channels. 

 
Note: To save Manual PCA sorting rules in Central, click on File > Save 
System Settings…. To load Manual PCA sorting rules, click File > Load 
System Settings…. To save PCA basis vectors, click File > Save PCA 
Basis…. To load PCA basis vectors, click File > Load PCA Basis…. 

k-means PCA 

1. Open the Hardware Configuration window and select one channels of 
interest. Multiple channels may be selected and sorted at once.  

2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “k-means PCA” from the spike sorting drop down menu. 
4. From the Central Suite main window select Tools > Auto Spike Sorting 

Method > All PCA Spike Sorting to begin the sorting process on all 
channels previously selected. 

5. Open Single Neural Channel and select the channel of interest from the 
drop-down menu. 

6. Make sure the unit icon is pressed down so you can see the units 
window. 

7. Click on the Feature tab. 

8. Click on Build PCA. By default the program needs 250 waveforms to build 
the PCA basis vectors. The time required to record 250 waveforms will 
depend on your spike rates and may take several minutes. You can 

 
Figure 40 – PCA Basis Waveforms 
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modify the number of waveforms used in Hardware Configuration > Spike 
Sorting. 

9. Wait for feature points to be generated. Clustering accuracy will improve 
as the number of feature points increases. 

10. Click on the k-means button to define separate groups. 
 
Note: To save k-means PCA sorting rules in Central, click File > Save 
System Settings…. To load k-means PCA sorting rules, click File > Load 
System Settings…. To save PCA basis vectors, click File > Save PCA 
Basis…. To load PCA basis vectors, click File > Load PCA Basis…. 

DBSCAN PCA 

1. Open Hardware Configuration window and select the channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “DBSCAN PCA” from the spike sorting drop down menu. 
4. Open Single Neural Channel and select the channel of interest from the 

drop-down menu. 
5. Make sure the unit icon is pressed down so you can see the units 

window. 
6. Click on the Feature tab. 
7. Click on Build PCA. By default the program needs 250 waveforms to build 

the PCA basis vectors. The time required to record 250 waveforms will 
depend on your spike rates and may take several minutes. You can 
modify the number of waveforms used in Hardware Configuration > Spike 
Sorting. 

8. Wait for feature points to be generated. Clustering accuracy will improve 
as the number of feature points increases. 

9. Click on the DBSCAN button. 
 
Note: To save DBSCAN PCA sorting rules in Central, click File > Save 

System Settings…. To load DBSCAN PCA sorting rules, click File > Load 
System Settings…. To save PCA basis vectors, click File > Save PCA 
Basis…. To load PCA basis vectors, click File > Load PCA Basis…. 

Use Adaptive Filtering 

Adaptive filtering can be used to remove a known noise signal from neural data. 
Common noise sources include experimental monitors, subject reward systems, and 
equipment racks.  Identify the potential external noise source and connect it to the NSP 
using an analog input BNC connector. 

1. Plug the peripheral noise source into an analog input channel. 
2. Open Hardware Configuration > Adaptive Filtering. 
3. Right click the channel icon and select properties. 
4. Select one or two channel operation. 
5. Select the analog inputs used for the noise sources as reference channels. 
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Create a Digital Filter 

Central Suite includes preset high pass, low pass and band pass filters. Filter 
parameters can be viewed in Hardware Configuration > Settings > Filters. The Digital 
Filter Editor allows you to construct custom filters.  

1. Open Central. 
2. Click on Digital Filter Editor. This tool requires MATLAB Compiler Run-time which 

is available on the Central Software Suite Installation CD and 
Blackrockmicro.com. 

3. Choose a filter type and the corner frequencies desired. If the filter is unstable 
the filter design tool will warn you and suggest ways to make the filter more 
stable. 

4. Save the filter in a known location and exit the Digital Filter Editor. 
5. In Central, click on File > Load Digital Filters. 
6. Select up to four custom filters in the loading dialog.   
7. All newly added filters will be available in the drop-down menu under Hardware 

Configuration for analog inputs. 

Rename Multiple 
Channels 

Central has a built-in automatic channel 
naming scheme with several parameters.  

1. Open Hardware Configuration. 
2. Select non-contiguous channels by 

holding down <Control> while 
selecting or select a range of 
channels by holding down the 
<Shift> key and clicking the upper 
and lower bounds of your selection.  

3. Right click and choose Properties. Alternatively, you can click on the “Properties” 
icon in the toolbar. 

4. Click the Edit button next to Label. 
5. Enter a label prefix you want across all selected channels. 
6. Choose a numbering scheme to be applied to each file after the prefix: 

a. Use current numbering: Maintain current channel numbering. 
b. Number channels sequentially starting at: Increment numbering from the 

start value by adding one to each additional channel. 
c. Number using channel ID: Number with the channel ID value going from 1 

to 128. 
d. Use terminal numbering: Number with the pin and bank value of the 

channel location on the front-end amplifier. 
 

  

 
Figure 41 – Label Options 
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Remotely Control Data Recording 

Central software can be configured to start and stop recording when triggered by a 
digital input coming from other hardware, such as a behavioral control system. When 
using the TOC file format, the recording can be remotely started, stopped, resumed, or a 
new session can be initiated. When using the2.x file format, the recording can be 
remotely started, stopped, paused, and resumed. To setup remote recording using the 
DB-9 serial port or DB-37 digital input port do the following: 

1. Open the File Storage app, check the Remote Recording box, and click Setup. 
2. Select Digital Bit Input for any of the four remotely controllable tasks. 
3. On the second column choose a bit to be used for this function. 
4. On the third column choose high or low for triggering. 

For example, to remotely begin recording when digital bit 3 on the digital input port is set 
high, configure as shown below. 

Visualize an Input Channel on the Digital 
Oscilloscope 

The Digital Oscilloscope enables you to visualize two channels at high resolution. 
Setting a trigger can improve visualization of signals. To setup the oscilloscope, follow 
the instructions below.   

1. Open Central and in the main window click the Oscilloscope. 
2. Enable Trace 1 and/or Trace 2. 
3. Select a channel for each trace from the drop-down menu. 
4. Click on Settings to verify all channel settings. Make sure a sampling rate is 

selected for the given channel. If <none> is selected for sampling rate then a 
trace will not appear in the Oscilloscope. 

5. Set the amplitude of each trace by changing the slider bar for each channel. The 
upper slider modifies the range of values and the lower slider selects a value 
within the selected range. The units are µV/division.  

6. Move the trace location up or down by dragging the small triangle on the left of 
the trace. 

7. Set the time resolution by changing the resolution slider bar. The upper slider 
modifies the range of values and the lower slider selects a value within the 
selected range. The highest resolution is 0.1 milliseconds.  

8. A trigger can be set for the traces.  
a. Choose a channel source for the trigger. 
b. You can set the trigger level by entering a voltage value in the field or by 

sliding the trigger line up and down on the display. 
c. Assign a trigger delay. At a default of zero, the trigger will be placed at the left 

edge of the screen and may not be visible. Negative values move the trigger 
to the right. 

 
Figure 42 – Example Settings for Remote Recording 
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9. Select a trigger type of Single, Normal, or Auto. 
a. Auto: Continuous signal will be displayed until the trace crosses the user 

defined trigger level.  When the trigger level is crossed, the trace will pause 
for two seconds, then resume until another triggering event occurs. 

b. Normal: The trace will freeze as soon as the trace crosses threshold until the 
trace crosses the trigger level again in which case the screen will update. 

c. Single: A single trace is captured as soon as it crosses the trigger level. To 
capture another threshold-crossed trace click on Single again. 

Configure Raster Plot  

The Raster Plot can display the occurrence of spike events or continuous signals for 
many channels over time. The plot can be configured to match your experimental setup. 

1. Begin by removing all channels from the display using the  clear all button. 

2. Open the  choose channels display and select the channels of interest.  

3. Use the  move buttons to order the selected channels. 

4. All channels can be  split into component channels. This will display a line for 
each classified spike unit as well as a continuous signal trace 

5.  Delete any unwanted channel components. 

6.  Resize channels of interest. It is often helpful to increase the size of 
continuous data traces. 

7. Adjust the  seconds per division of the markers on the plot. 

8.  Change the font size for channel labels to be easily read.  
 

For an explanation of further Raster Plot functionality see Page 28. 
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Figure 43 – Sample CMP File 

 

Change Electrode Map (Create a Map File) 

It is possible to re-arrange the electrode positions on Spike Panel and Activity Map. A 
plain text “map” file contains the location assignments of each channel. A sample map 
file is included below. 

 

// 8-Channel NSP map file demo 

// 

// Data is as follows, 'C(olumn) r(ow) b e l' 

//   c - 0 based column from left to right 

//   r - 0 based row from bottom up 

//   b - bank name - values can be A, B, C, or D 

//   l - label used to rename channels in Central 

// 

// Comments begin with '//' 

// First non-comment line is the Mapfile description 

// 

8 Channel NSP mapping 

0 1 A 4 elec08 

1 0 A 8 elec07 

2 1 A 3 elec06 

3 0 A 6 elec05 

0 0 A 5 elec01 

1 1 A 2 elec02 

2 0 A 7 elec03 

3 1 A 1 elec04 

 

 
Figure 44 – Sample Spike Panel 
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The map file contains five columns. The first column indicates the location of the spike 
window on the x-axis. The second column indicates the location of the spike panel on 
the y-axis. Point 0,0 is on the lower left corner of the screen. The third column indicates 
the bank the physical channel is located on (A, B, C, or D) and the fourth column 
indicates the bank pin the channel is connected to. The fifth column is optional and 
defines the label for the channel. 

In the example above, the first line indicates that the channel on bank A pin 4 is named 
elec08 and it’s located on the 1st column from left (0) and the 2nd row from the bottom 
(1). The last line indicates that the channel on bank A pin 1 (channel 1) is named elec04 
and it should be placed on the 4th column (3) from left and the 2nd row from bottom (1). 
Location positions start from 0. Any line that starts with “//” will be used as comment and 
will be ignored. The first line after the last // line is the name of the map file as referenced 
in the apps and will also be ignored. 

Test Impedance with a CerePlex Headstage 

1. Set headstage switch to impedance mode. 
2. Click on Impedance Tester in the main window of Central. The Auto Impedance 

app will open. If data is being recorded, you will be prompted to stop recording or 
cancel the impedance test.  

3. Impedance data is collected then the Auto Impedance screen is displayed. All 
channels are measured sequentially in less than one minute. Impedance 
readings are displayed for every channel with a default tolerance of 100-800 Ω. 
Channels out of tolerance will turn yellow (below) or red (over) to indicate out of 
range values. 

4. Open View > Options to display the Impedance Calculation Settings. 
5. Open the Edit menu or right-click one of the bad channels to display the 

properties menu. 
6. Select Disable Bad Channels to mark out-of-tolerance channels, the disabled 

channels will be blank or marked with an “X” throughout Central. 
7. Click File > Save Values to save impedance values. 
8. Click File > Exit to quit Impedance testing. 
9. Return switch to recording mode. 
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Record a Video using NeuroMotive  

A video file can be recorded in sync with neural data recorded using NeuroMotive.  

1. Connect an NSP or CerePlex Direct to the Host PC. 
2. Run Central. 
3. Start NeuroMotive and make sure the video camera is connected properly and 

selected. 
4. Open File Storage in Central and prepare it for recording as desired. 
5. Make sure File Specification is 2.3, TOC 2.0, or higher and the File application is 

synchronized with NeuroMotive. In the File application go to View > Options > 
Sync with NeuroMotive if present. 

6. A NeuroMotive indicator should appear in the File application dialog. 

7. Record continuous data for later analysis in nPlay Server. 
8. Start neural recording through the Central File Storage application. 
9. Video recording will start automatically in NeuroMotive. NeuroMotive will 

duplicate the filename specified in the Central File Storage application. If the 
filename chosen is already being used by another video file in the recording 
directory, then NeuroMotive will automatically append an incrementing counter to 
the filename. 

10. NeuroMotive will continue recording when Central is paused. 
 

  

 
Figure 45 – File Application Connected to NeuroMotive™  
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Troubleshooting/Error Messages 
Central error messages and common solutions are listed here. Once these steps are exhausted 
please contact Blackrock Support.  

Files are currently being recorded.  Do you want to 
stop recording and close the app? 

The user has attempted to close the Central Main Window while recording is 
ongoing. To avoid this error, always stop recording before attempting to close the 
software.  

Unable to allocate shared Memory 

Both Central Software Suite and another utility have attempted to connect to the 
NSP via UDP. To remedy this, shut down any utilities, such as cbMEX, or 
cbSDK, that may be attempting to communicate with the NSP.  

Recording is currently blocked by another utility.  
Please close that utility and try again. 

A utility within the Central Suite is interfering with recording. Check to see if 
impedance mode is running. If not, restart your Host PC and try recording again.  

Unable to open the Central Application! 

An error has occurred within the Central Main Window startup. Restart your Host 
PC and reinstall Central Suite.  

The basis vectors have not yet been calculated for 
this channel. 

Please Build PCA then retry 

The user has attempted to save spike sorting settings before generating sorting 
rules. Define spike sorting rules in the Single Channel Viewer Window before 
saving.   

There may not be enough data points to effectively 
calculate the ellipsoids. 

Would you like to continue? 

An insufficient number of detected spikes have been recorded to create ellipsoid 
groupings on the PCA space. Wait until more spikes are recorded before 
attempting to define ellipsoids. Proceeding with fewer spike events is possible 
but may not produce accurate unit definitions.  
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CerePlex Direct is not Connected to a High Speed 
USB Port.  

The CerePlex Direct requires a USB 2.0 port or higher to work. 

The CerePlex Direct is connected to a USB 1.0 port. It is advised to connect the 
Direct through a high-speed USB 2.0 port.  

No CerePlex Direct Detected. 

This error occurs when the Central Software Suite does not recognize a 
connection to the Cereplex Direct. To remedy this, attempt the following steps: 

1. Confirm that a CerePlex Direct is connected and powered on. 
2. Try connecting the CerePlex Direct to a different USB port. 
3. Restart the CerePlex Direct, and the Host PC. 
4. Uninstall the Cereplex Direct software and the USB driver for the Direct. 
5. Disconnect the Direct, reinstall the Cereplex Direct software and 

reconnect the Direct. 

Unable to Open Instrument Network 

OR 

It appears that the instrument network has failed. 

Central cannot communicate with the NSP. If this occurs, confirm that: 

1. The NSP is powered on. 
2. An ethernet cable connects the NSP and the Host PC. 
3. If a switch is used, it is connected correctly and powered on. 
4. The Ethernet port has been configured as described in the Setup section 

on Page 7. 

Once confirmed, restart the NSP and Host PC. 

Network packets have been lost between the NSP 
and this PC. 

This is most likely caused by the system load 
being higher than 8 MB/s. 

OR 

Network packets have been lost between the PC 
and the instrument  

These errors occur when the Central Software Suite intermittently fails to 
communicate with the NSP over ethernet. To remedy this, confirm that: 

1. The NSP is still powered on, and is connected to the Host PC with an 
ethernet cable.  

2. No other applications are consuming significant system resources. 
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If so, attempt the following: 

1. Disable Windows Firewall, Defender, Restore, Sound, Automatic Update, 
System Notifications, and other Ethernet ports. 

2. Uninstall anti-virus and any unnecessary software.  

The system is initializing, please wait. 

If the system doesn't respond, click the Reset NSP 
button below. 

This error occurs when the Central Software Suite recognizes an NSP that is not 
initialized. When this error message occurs, confirm that the NSP screen also 
shows the “Initializing” message. If so, wait for up to a minute before resetting the 
NSP. Attempt to reset with the software button included in the error message 
before doing a hardware reset with the switch on the front of the NSP.  

Network packets have been lost between the NSP 
and this PC. 

This is caused by the system load being higher than 12 MB/s 

This error occurs when data is possibly lost within the NSP and is not sent to the 
PC. To remedy this error, confirm that your NSP is running the latest firmware 
available in the Software Downloads section of Blackrockmicro.com.  

Data Recording Restarted. 

The data load to the PC is extremely high and data 
storage has been restarted. Please reduce the 
burden on your PC and restart data collection. 

This error occurs periodically in very long duration recordings. To remedy this, 
attempt the following: 

1. Disable Windows Firewall, Defender, Restore, Sound, Automatic Update, 
System Notifications, and other Ethernet ports. 

2. Uninstall anti-virus and any unnecessary software.  
3. Close any other active applications. 
4. Reduce the number and rate of continuously sampled channels. 
5. Consider a faster PC or hard drive, such as a solid state drive. 
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Support 
Blackrock prides itself in its customer support. For additional information on this product or any 
of our products, you can contact our Support team through the contact information below: 

 
Manuals, Software Downloads, and Application Notes 
www.blackrockmicro.com/technical-support 

Complaints 

When filing a complaint, please provide the product description, product number, 
software version, lot number, complainant's name and address, and the nature of the 
complaint. 

 
Issues or Questions 
www.blackrockmicro.com/technical-support 
support@blackrockmicro.com 

U.S.: +1 (801) 582-5533 
Europe: +49 (0) 511 132 211 10 
 

Notice to the user and/or patient that any serious incident that has occurred in relation to the 
device should be reported to the manufacturer and the competent authority of the member state 
in which the user and/or patient is established. 

 

http://www.blackrockmicro.com/technical-support
http://www.blackrockmicro.com/technical-support
mailto:support@blackrockmicro.com

